A critical cybersecurity vulnerability has been discovered in Cisco Prime Collaboration Provisioning software. This cybersecurity vulnerability can be used by a local hacker to elevate privileges to root and take full control of a system.
Cisco Prime Collaboration Provisioning (PCP) application allows administrators to remotely control the installation and management of Cisco communication devices (integrated IP telephony, video, voicemail) deployed in the company and services for its subscribers.
This app is affected by the vulnerability (CVE-2018-0141) which is present because the app has a hard-coded password for Secure Shell (SSH).
Cisco PCP Hard-Coded Password Flaw
This vulnerability has a Common Vulnerability Scoring System (CVSS) base score of 5.9 out of 10, but we say that this cybersecurity problem is rated as critical because any cybercriminal could use it to elevate their privileges to root.
We have detected this cybersecurity problem while running some cybersecurity testing. CVE-2018-0141 only affects PCP version 11.6, released in November 2016.
Cisco has patched this vulnerability in its Cisco PCP software version 12.1.
Running cybersecurity tests is essential for every respectable company. To be adequately protected, you must contract a cybersecurity company that will carry some advance cybersecurity tests to your company networks, like penetration tests, and ethical hacking tests. This kind of checks must be made every year because cyber security threats evolve and you must find and fix any cybersecurity flaws as soon as they are discovered. If you are not running Linux, the presence of antivirus for Windows or antivirus for Mac is a must in every device that you own.
Cisco Secure ACS Remote Code Execution Flaw
In Cisco PCP software version 12.1, the company has also patched a critical cybersecurity problem – named Java deserialization vulnerability which was affecting Secure Access Control System (ACS).
Cisco Secure ACS flaw (CVE-2018-0147) can be used by a cybercriminal to remotely execute malicious code on vulnerable devices with root privileges without using any credentials.
This critical cybersecurity problem has a Common Vulnerability Scoring System (CVSS) base score of 9.8 out of 10, and it affects all versions of Cisco Secure ACS before release 5.8 patch 9.
Cisco fixed it in Cisco Secure ACS 220.127.116.11.9 Cumulative Patch.
We are actively recommending every user to update their software to the latest versions as soon as possible. Also, we must remind that implementing a cybersecurity solution like antivirus on every device that you own is a must if you want to be adequately protected.